[-]
Szybkie szukanie


Baner sklepu jdtech.pl
Odpowiedz 
 
Ocena wątku:
  • 0 Głosów - 0 Średnio
  • 1
  • 2
  • 3
  • 4
  • 5
Problem z instalacją modemu na Linuxie (Centos 7)
26-11-2019, 12:38
Post: #1
Problem z instalacją modemu na Linuxie (Centos 7)
Posiadam modem E3131 (Play) z kartą z Plusa. Na Win10 mam maszynę wirtualną z Centos 7. Na Win10 mam zainstalowany program Top net info i połączenia działa. Na Win10 i Centosie wykrywa jako CDROM. Chodzi o to, żeby modem działał na Centosie. Chciałem zrobić według wątku ale jest problem w pierwszym kroku.

Kod:
[root@localhost ~]# lsusb
[root@localhost ~]# df -h
Filesystem               Size  Used Avail Use% Mounted on
/dev/sr0                  34M   34M     0 100% /run/media/rh/PLAY ONLINE
[root@localhost ~]#

Urządzenie widać jako cdrom (sr0) ale nie widać w lsusb.
Kod:
[root@localhost ~]# lsusb --version
lsusb (usbutils) 007
[root@localhost ~]# usb_modeswitch --version

* usb_modeswitch: handle USB devices with multiple modes
* Version 2.5.1 (C) Josua Dietze 2017
* Based on libusb1/libusbx

Urządzeń /dev/ttyUSB0,1,2 też nie ma.
Kod:
[root@localhost ~]# ls /dev/ttyUSB*
ls: cannot access /dev/ttyUSB*: No such file or directory
[root@localhost ~]#

Po wykonaniu polecenia:
Kod:
[root@localhost ~]# modprobe option
[root@localhost ~]# dmesg
[  212.107283] usbserial: USB Serial support registered for GSM modem (1-port)
[root@localhost ~]#
[root@localhost ~]# dmesg | grep tty
[    0.000000] console [tty0] enabled
[    0.583947] 00:03: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[    0.678465] 00:04: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A

Zacząłem działać z poleceniami wvdial i usb_modeswitch ale zakładam, że problem jest na początku (nie wyświetla nic z lsusb) i dalej nie można nic zadziałać. Proszę o pomoc.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
26-11-2019, 16:18
Post: #2
Problem z instalacją modemu na Linuxie (Centos 7)
Zacznijmy od tego, że wszystko zależy od tego, jak twój host i hypervisor podłączają to urządzenie. Powinny odpiąć całkowicie od hosta (modem i wszystkie jego urządzenia mają zniklnąć z menedżera urządzeń) i przypiąć do maszyny wirtualnej. I teraz może to być na poziomie koncentratora USB (i pod urządzeń), albo będziesz podłączał każde urządzenie modemu (a jest ich z 5 w trybie CD i do 12 w trybie modemu) do maszyny wirtualnej.

Ogólnie zwykle dawałem sobie z tym spokój i podłączałem do hosta, po czym udostępniałem net przez NAT. Za dużo walki, za mało profitów, ale powinno się udać.

Teraz za pewne masz taki problem, że modem jest przypięty do hosta i wirtualny napęd CD jest udostępniony do VMki.

Jaki to hypervisor?
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
27-11-2019, 08:52
Post: #3
Problem z instalacją modemu na Linuxie (Centos 7)
jakubd napisał(a):Jaki to hypervisor?
Hyper-V
jakubd napisał(a):Teraz za pewne masz taki problem, że modem jest przypięty do hosta i wirtualny napęd CD jest udostępniony do VMki.
Dokładnie. Napęd CD jest udostępniony przez Hyper-V do Linuxa.
jakubd napisał(a):Powinny odpiąć całkowicie od hosta (modem i wszystkie jego urządzenia mają zniklnąć z menedżera urządzeń) i przypiąć do maszyny wirtualnej.
Dokładnie. Nic takiego się nie dzieje. Tylko przepina napęd CD i nic poza tym.
W Menadżerze urządzeń Windowsa są:
modem:
HUAWEI Mobile Connect - 3g Modem
porty:
HUAWEI Mobile Connect - 3G Application Interface (COM5)
HUAWEI Mobile Connect - 3G PC UI Interface (COM3)
I nic nie przepina do Linuxa. W sumie logiczne, jak CD to tylko CD.
Ogólnie to chce na Linuxie ogarnąć wysyłanie SMS z Zabbixa.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
27-11-2019, 10:00
Post: #4
Problem z instalacją modemu na Linuxie (Centos 7)
Gdzieś w ustawieniach HyperV powinny być opcje przekazania urządzenia w całości - nie wiem, nie używam akurat tego hypervisora. Jest coś takiego w VMWare i Virtualbox.
Jednak do testów dostępu sprzętowego do SMS nie potrzebujesz tego całego majdanu z rozpoznaniem i konfiguracją modemu (choć i tak wypadałoby to potem potestować na sprzęcie - patrz usb_modeswitch), więc możesz podłączyć już finalnie rozpoznany port szeregowy - HUAWEI Mobile Connect - 3G PC UI Interface (COM3) - o ile masz taką opcję gdzieś w ustawieniach maszyny wirtualnej w HyperV.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
06-12-2019, 12:50
Post: #5
RE: Problem z instalacją modemu na Linuxie (Centos 7)
Dałem sobie spokój z tym rozwiązaniem. Przewertowałem pół internetu i wniosek taki, że Hyper-v nie pozwala udostępniać USB. Ale obecnie testuje rozwiązanie USB Redirector (docelowo jest płatne) czyli udostępnianie USB przez sieć. Ale jest problem.
Jak modem podłączam na Win10 w programie top_netinfo to wysyła bez problemu sms. Skopiowałem więc te ustawienia APN do wvdial.conf na Linuxie.

[Obrazek: 9c3fb9a51121c.jpg]

[Obrazek: ddc5da3ef2114.jpg]

Odpalam wvdial plus i wisi (chociaż to jest ok bo przerywa się ręcznie połączenie):

[Obrazek: 5035c7a1edb4f.jpg]

ale jak odpalam wysyłkę:
[Obrazek: c9397b2c6cbef.jpg]
to tu wisi w nieskończoność (bez żadnego błędu)

[Obrazek: 808d195270370.jpg]

Co może być przyczyną?
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
07-12-2019, 02:03
Post: #6
Problem z instalacją modemu na Linuxie (Centos 7)
Zamiast używać od razu GAMMU, użyj gołej konsoli, tu masz przykładowe polecenia AT (wspólne dla wszystkich urządzeń GSM z interfejsem szeregowym):
https://hologram.io/blog/using-at-comman...awei-e303/

Co do pppd - nie powiedziałeś czy działa, czy nie - po nawiązaniu połączenia masz interfejs PPP (tak jak pokazałeś) i w zależności od tego, czy ustawił ci się route default na IP połączenia (zależy od ustawień demona pppd lub połączenia) to będzie działało, albo nie. Konsola ma zawisnąć, bo tak to działa - strumień TCP/IP po pppd idzie obok, sprawdzaj z kolejnej konsoli/terminala. Jako uławienie używa się wvdial, albo coś takiego.
Z tym, że pppd i SMS są kompletnie niezależne i w zasadzie jedno z drugim może się gryźć. Jak bym połączenia pppd nie nawiązywał, bo wtedy możesz zablokować sobie port od komunikacji z modemem (dlatego zwykle są 2-3 porty COM w modemach do konkretnych zastosowań).
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
Odpowiedz 


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  3131 Mac upgrade do Sierra PROBLEM nie działa Franka 3 2 135 28-04-2017 16:17
Ostatni post: jakubd
  Problem z modemem Huawei e3131 s2 Lorek 14 7 628 13-02-2017 19:36
Ostatni post: Lorek
  Huawei E3131s-2 (z Play) problem z dostępem do 3G poza Play Grzesiek260500 12 6 120 04-01-2017 23:57
Ostatni post: Grzesiek260500
  E3131, problem z połączeniem Piksel 5 3 636 28-12-2016 16:48
Ostatni post: jakubd
  Komputer nie czyta modemu. Yokachi 9 3 355 11-07-2016 14:56
Ostatni post: Yokachi