[-]
Szybkie szukanie


Baner sklepu jdtech.pl
Odpowiedz 
 
Ocena wątku:
  • 0 Głosów - 0 Średnio
  • 1
  • 2
  • 3
  • 4
  • 5
Huawei E3131 w Linuksie - problem z wvdial
17-11-2012, 13:27
Post: #1
Huawei E3131 w Linuksie - problem z wvdial
Panowie,
mam problem, otóż przygotowuje się do używania wvdial. Niestety pomimo tego, iż udało mi się ustanowić połączenie (jest success, modem daje na początku jasnoniebieski kolor diodą), mam w ifconfig połączenie ppp0, to nie mam dostępu do internetu...czy ktoś wie czemu?
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
17-11-2012, 16:34
Post: #2
RE: Wymuszanie UMTS 900 MHz w modemach Huawei
Ja mogę zaoferować tylko link: http://dug.net.pl/tekst/197/aero2_z_mode...wei_e3131/
Diagnozowanie tego co w stosie TCP/IP masz nie tak (od default gateway dla ppp0, przez ifconfig aż po diagnostyke pingiem) wychodzi zupełnie poza wątek o... wymuszaniu UMTS 900 MHz w modemach Huawei Smile
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
17-11-2012, 17:15
Post: #3
RE: Wymuszanie UMTS 900 MHz w modemach Huawei
(17-11-2012 13:27)odyniec napisał(a):  Panowie,
mam problem, otóż przygotowuje się do używania wvdial. Niestety pomimo tego, iż udało mi się ustanowić połączenie (jest success, modem daje na początku jasnoniebieski kolor diodą), mam w ifconfig połączenie ppp0, to nie mam dostępu do internetu...czy ktoś wie czemu?

Poprawnie wpisałeś konfigurację do pliku konfiguracyjnego?
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
18-11-2012, 18:41
Post: #4
RE: Wymuszanie UMTS 900 MHz w modemach Huawei
No wybacz Jakub,
może stwórz w razie czego podtemat o linuxie - pisali tu to się dołączyłem.
Otóż połączenie skonfigurowane poprawnie - łączy się modem, mam przez chwilę jasnoniebieską diodę, a potem cały czas się ciemnoniebieska..
Łączy się poprawnie, mam nawet komunikat o pobraniu DNS z sieci.
w ifconfig mam ppp0 z adresem IP zewnętrznym.
Natomiast ping nie daje odpowiedzi...
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
18-11-2012, 19:09
Post: #5
RE: Wymuszanie UMTS 900 MHz w modemach Huawei
A route co pokazuje? Niem wiem czy wvdial ustawia to po połączeniu.

Ja bym ci radził ściągnąć skrypt Sakis3G on cię za rękę poprwadzi i połączy z Aero2.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
18-11-2012, 21:34
Post: #6
RE: Huawei E3131 w Linuksie - problem z wvdial
pppd powinien sam ustawić route - ale cholera go wie, czy to robi - mamy za mało informacji do postawienia diagnozy.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
18-11-2012, 22:12
Post: #7
Wymuszanie UMTS 900 MHz w modemach Huawei
Słuszna uwaga - route!
Route nie ustawia się wraz z uruchomieniem wvdial'a.
Zdefiniowałem ręcznie i jestem...teraz tylko dlaczego wvdial nie ustawia route'a?
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
18-11-2012, 22:14
Post: #8
RE: Huawei E3131 w Linuksie - problem z wvdial
Jeśli masz Huawei e173 to spróbuj Sakisa
Kod:
sudo ./sakis3g connect --console APN="CUSTOM_APN" USBINTERFACE="0" USBDRIVER="option" MODEM="12d1:140c" CUSTOM_APN="darmowy" APN_USER="user" APN_PASS="pass"
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
19-11-2012, 15:29
Post: #9
Odp: RE: Huawei E3131 w Linuksie - problem z wvdial
(18-11-2012 22:14)p4trykx napisał(a):  Jeśli masz Huawei e173 to spróbuj Sakisa
Kod:
USBDRIVER="option" MODEM="12d1:140c"

Jestem lama w pingwinie Wink ale czemu option jak modem Huawei?
Chyba że to nie ma znaczenia może być "misiu" tylko ważny ten parametr "12d1:140c"



Wysyłane z mojego GT-I9000 za pomocą Tapatalk 2
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
19-11-2012, 16:34
Post: #10
RE: Huawei E3131 w Linuksie - problem z wvdial
"option" to nazwa modułu jądra, który obsługuje modemy firmy Option i pewnie przez to, że jest bardzo podobny w działaniu to obsługuje też modemy Huawei.
Sakis3G chyba jest na tyle bystry, że wie, że urządzenie usb 12d1:140c to właśnie modem Huawei i obsługuje go moduł opiton więc może nie trzeba podawać tego parametru.

Sakis3g chyba w razie problemów potrafi przeładować moduły jądra od modemu przez go zresetować.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
27-11-2012, 21:11
Post: #11
RE: Huawei E3131 w Linuksie - problem z wvdial
No wiec wpisałem jak kolega radził i Linux nie wita mnie dobrze
Mam taki komunikat:

Device did not report GSM capabilities. You can skip this by adding --noprobe command line switch.
Failed to connect.

Modem w tej chwili posiada nową kartę niestety wita mnie migająca dwa razy na zielono diodą...i to chyba tu pogrzebany pies...
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
27-11-2012, 21:34
Post: #12
RE: Huawei E3131 w Linuksie - problem z wvdial
Nie bardzo wiem, o co chodzi z Twoim problemem. Jakiej dystrybucji używasz i jak masz skonfigurowany plik dla wvdial?

Używam Kubuntu i wvdial oraz e173u-2, a czasem 3131 i zawsze oba działają. W konsoli uruchamiam wvdial i łączy, i wznawia połączenia.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
27-11-2012, 23:44
Post: #13
RE: Huawei E3131 w Linuksie - problem z wvdial
ubuntu 12.04.

wvdial conf =

[Dialer aero]
Modem = /dev/ttyUSB0
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2
Init3 = AT+CGDCONT=1,"IP","darmowy"
Init4 = AT&C1
Carrier Check = no
#;Modem Type = Analog Modem
Phone = *99***1#
Dial Command = ATDTW
ISDN = 0
Auto DNS = 1
apn = darmowy
Username =;
Password =;
Init1 = ATZ
Baud = 9600
Stupid mode = Yes


Probowałem również przez sakiza...też jakiś error mi idzie...
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
28-11-2012, 00:31 (Ten post był ostatnio modyfikowany: 28-11-2012 00:44 przez mistrz1.)
Post: #14
RE: Huawei E3131 w Linuksie - problem z wvdial
Cytat:[Dialer Defaults]
Modem = /dev/ttyUSB0
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2
Init3 = AT+CGDCONT=1,"IP","darmowy"
Init4 = AT&C1
Carrier Check = no
;Modem Type = Analog Modem
Phone = *99***1#
Dial Command = ATDTW
ISDN = 0
Auto DNS = 1
apn = darmowy
Username =;
Password =;
Init1 = ATZ
Baud = 460800
Stupid mode = Yes
Tak wygląda mój plik o nazwie: wvdial.conf
W porównaniu z Twoim są różnice, ale nie wiem, czy one są decydujące. Może skopiuj i sprawdź, czy zadziała?

Poza tym, za nim uruchomisz wvdial wydając komendę w konsoli, modem musi migać na niebiesko.
Ubuntu 12.04 ma zainstalowane wszystkie potrzebne sterowniki do obsługi tego modemu. Nic nie trzeba instalować. Podpinasz modem, czekasz aż zacznie migać na niebiesko, uruchamiasz konsolę:
Cytat:$ sudo pon.wvdial
i działa. Miałem wersję Kubuntu 12.04 i działało, nawet na Kubuntu 11.10 działało. Nic nie trzeba doinstalowywać. Działa nawet na LiveCD. Od wersji 12.04 w NM jest nawet już gotowy profil aero2, wybierasz i hula.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
28-11-2012, 01:03
Post: #15
RE: Huawei E3131 w Linuksie - problem z wvdial
Zastosowałem się do Twoich porad, oto efekt:

--> No Carrier! Trying again.
--> Sending: ATDTW*99***1#
--> Waiting for carrier.
ATDTW*99***1#
NO CARRIER

Czy może muszę wymusić mu te WCDMA 900 Mhz?
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
28-11-2012, 01:07 (Ten post był ostatnio modyfikowany: 28-11-2012 01:09 przez mistrz1.)
Post: #16
RE: Huawei E3131 w Linuksie - problem z wvdial
Ten komunikat oznacza, że modem nie zalogował się do sieci, czyli jesteś poza zasięgiem i modem miga na zielono. Musi najpierw złapać sygnał i migać na niebiesko, dopiero wtedy uruchamiasz wvdial. Szukałbym przyczyny w modemie. A używając NM działa?
Modem loguje się do sieci i miga na niebiesko?
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
28-11-2012, 01:42
Post: #17
RE: Huawei E3131 w Linuksie - problem z wvdial
Właśnie nie...ani jedno ani drugie.
Na windowsie szukam zasięgu, mam od 40-60% w częstotliwości 2100. Niestety modem miga mi na zielono dwukrotnie za każdym razem...
Raz mignął mi na ciemnoniebieski ale wtedy też nie chciał się połączyć...
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
28-11-2012, 01:50
Post: #18
RE: Huawei E3131 w Linuksie - problem z wvdial
Coś przekombinowałeś z modemem. Ustaw tak, jak jest to tu opisane i musi działać. http://jdtech.pl/2011/08/aero2-na-czym-p...-e169.html
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
28-11-2012, 02:05
Post: #19
RE: Huawei E3131 w Linuksie - problem z wvdial
Mam ustawione
Automat;
WCDMA, potem GSM;
Pasmo - wszystkie;
Roaming - ON;
KomutacjaCS i PS.

Sygnału od 20 procent do nieraz 60%.

Dioda miga na zielono...
Jakieś inne idee?
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
28-11-2012, 02:11 (Ten post był ostatnio modyfikowany: 28-11-2012 02:12 przez mistrz1.)
Post: #20
RE: Huawei E3131 w Linuksie - problem z wvdial
Coś jest nielogicznego. Jeśli pokazuję siłę sygnału, to znaczy, że zalogował się do sieci i miga na niebiesko. Zresetuj modem. A później wykonaj wszystkie kroki konfiguracji modemu.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
Odpowiedz 


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Problem z instalacją modemu na Linuxie (Centos 7) gumis_148 5 1 686 07-12-2019 02:03
Ostatni post: jakubd
  Huawei - ostatnia oficjalna i dostępna wersja Mobile Partner szopen 0 2 160 25-08-2019 12:50
Ostatni post: szopen
  Huawei E3131 Firmware lukkki 74 154 361 24-12-2018 14:49
Ostatni post: jakubd
  huawei E3131 top netinfo połaczony AERO2,neta brak adikSl 9 4 262 09-12-2018 17:07
Ostatni post: szopen
  Huawei 3131 Hlink, wszystko ok ale connection failded bereal 4 2 608 06-12-2018 00:19
Ostatni post: bereal