[-]
Szybkie szukanie


Baner sklepu jdtech.pl
Odpowiedz 
 
Ocena wątku:
  • 0 Głosów - 0 Średnio
  • 1
  • 2
  • 3
  • 4
  • 5
D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
05-02-2018, 22:34 (Ten post był ostatnio modyfikowany: 06-02-2018 00:22 przez jakubd.)
Post: #1
D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
Witam. Zakupiłem router D-Link drw-116 i podłączyłem do niego modem Huawei E3131-s2. Problem polega na tym, że router nie widzi modemu, nie nawiązuje połączenia. Modem wcześniej działał z Huawei D100 bez zarzutu.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
06-02-2018, 00:20 (Ten post był ostatnio modyfikowany: 06-02-2018 00:26 przez jakubd.)
Post: #2
D-Link drw-116 + Huawei E3131-s2 router nie widzi modemu
Router nazywa się DWR-116, a nie DRW-116. Poprawiłem tytuł wątku.
Musisz napisać coś więcej o problemie. Na razie mam SOA#1 - "u mnie działa".
DWR-116 firmware V104(EU)
Modem E3131s-2 wersja z Play, tradycyjny
Karta SIM: Orange
Po podłączeniu router wykrył modem, przełączył w tryb modemu i odpalił połączenie:
Kod:
Feb 5 23:14:25    O3G/modem_switch: MODEM_SWITCH [0x12d1] [0x14fe]
Feb 5 23:14:37    O3G/usblist: 3G modem VendorID=[12d1] ProductID=[1506]
Feb 5 23:14:38    O3G/usblist: chk_interface_num ret:6
Feb 5 23:14:58    O3G/3g_queryd_0: check_modem_info[imsi=260034667080615]
Feb 5 23:14:59    O3G/3g_queryd_0: check_modem_info[imei=862571022719550]
Feb 5 23:15:00    O3G/3g_queryd_0: check_modem_info[model=E3131^M]
Feb 5 23:15:01    O3G/3g_queryd_0: check_modem_info[signal_strength=70]
Feb 5 23:15:02    O3G/3g_queryd_0: check_modem_info[network_name=Orange][service_type=2]
(...)
Pytania pomocnicze:
1. Jak stwierdzasz, że router nie widzi modemu? (a nie np. nie potrafi nawiązać połączenia, bo używasz operatora z nietypowym APNem?)
2. Jaka karta SIM/usługa/operator?
3. Jaka wersja firmware routera?
4. Jakie pochodzenie modemu i tryb pracy?

PS: jesteś nowym użytkownikiem forum twoje posty podlegają moderacji, więc poczekaj chwilę po naciśnięciu odpowiedzi - ktoś z ekipy musi zatwierdzić wiadomość, może przy okazji odpisze Smile
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
06-02-2018, 00:56 (Ten post był ostatnio modyfikowany: 06-02-2018 00:59 przez szopen.)
Post: #3
D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
1) przede wszystkim, to router trzeba poprawnie skonfigurować, bo dwr-116 obsługę modemów USB ma dostępną jako jedną z kilku opcji (tu widać o co chodzi)
http://forum.jdtech.pl/Watek-d-link-dwr-...3#pid38973
a D100 jeśli się nie mylę nie ma innych opcji niż modem jako WAN, więc jego konfiguracja jest łatwiejsza

2) zbiór firmware (firmware zmieniamy o ile faktycznie jest to konieczne i TYLKO po przeczytaniu i zrozumieniu instrukcji jak to zrobić, w szczególności tych fragmentów mówiących o zachowaniu cierpliwości, tj. bezwzględnym NIE odłączaniu zasilania w trakcie flashowania oraz o konieczności przywrócenia ustawień fabrycznych przed konfiguracją, a już po zmianie firmware)
tu najnowsze 1.06 b03
ftp://ftp.dlink.de/dwr/dwr-116/driver_software/
a tu kilka starszych w tym wspomniane wyżej przez Jakuba 1.04 (oraz 1.03 b03, które z jakiegoś powodu mam oznaczone w domowym archiwum jako zalecane do modemów typu hilink, ale ta informacja może nie być aktualna)
ftp://ftp.dlink.eu/Products/dwr/dwr-116/..._software/

Statystyki Folding@home
[Obrazek: sigimage.php?un=szopen&t=247478]
Odwiedź stronę użytkownika Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
06-02-2018, 10:17
Post: #4
D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
szopen napisał(a):oraz 1.03 b03, które z jakiegoś powodu mam oznaczone w domowym archiwum jako zalecane do modemów typu hilink, ale ta informacja może nie być aktualna
Chodzi o to, że te niższe firmware nie przełączają na siłe HiLinków do trybu tradycyjnego. Czy to zaleta, czy wada, to sprawa dyskusyjna.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
06-02-2018, 11:25
Post: #5
D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
Mały OT: są łatki do openwrt żeby wspierało DWR-116, więc będzie alternatywny soft i wspierane więcej modemów.
Odwiedź stronę użytkownika Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
06-02-2018, 11:34
Post: #6
D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
Dzięki Cezary! Obserwuję wątek, bo mam ten sprzęt w ręku.
Tutaj mamy z pewnością jakiś inny problem, bo fabrycznie E3131 we wszystkich wersjach powinien działać. Ale wiadomo, że Gargoyle czy nawet LEDE/OpenWRT to inna klasa.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
06-02-2018, 14:07
Post: #7
D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
Racja, "DWR". Dziękuje za poprawienie. Modem czysty, bez znaczków operatorów - zwykły (nie HiLink) , simlocka itp. ustawiony na tryb "tylko WCDMA" Router natomiast z Play z softem V1.06(PL). Kartę sim mam z play. To, że router nie widzi modemu wnioskuje po tym, że w ustawieniach routera w zakładce status>WAN nie ma żadnych informacji (status sieci, siła sygnału itp.).
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
06-02-2018, 14:47 (Ten post był ostatnio modyfikowany: 06-02-2018 15:12 przez szopen.)
Post: #8
D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
1) a czy skonfigurowałeś router do używania modemu do korzystania z modemu jako interfejsu WAN? (w podlinkowanym wyżej poście z innego wątku na SS widać gdzie to należy ustawić)

2) jeśli jesteś pewien, że nie jest nic namotane w ustawieniach routera to przygotuj SS z menu setup i advanced ze wszystkich istotnych podmenu (nie mam bladego pojęcia czy tak samo to się nazywa w spolszczonym interfejsie)

3) ale zakładając, że coś w konfiguracji może być namieszane to pierwsze co bym zrobił, to przywrócił ustawiania fabryczne routera (system->tools->restet to default)
oraz ewentualnie wyłączył wymuszenie 3G w modemie (chodzi o włączenie standartowych ustawień pasm w Mobile Partnerze, nawet jeśli masz problemy z zasięgiem w 3G)

edit: po tym co zobaczyłem na forum Play Tongue - przed przywróceniem ustawień fabrycznych sprawdź czy masz defaultowe hasło logowania do panelu administracyjnego (webGUI) na tabliczce znamionowej (wersja 1.06 wprowadza to hasło, we wcześniejszych wersjach fw było ono po prostu puste…)


jakubd napisał(a):Chodzi o to, że te niższe firmware nie przełączają na siłe HiLinków do trybu tradycyjnego. Czy to zaleta, czy wada, to sprawa dyskusyjna.
też tak mi się wydawało, że to ostatni firmware, który nie przełącza hilinków na siłę, ale tu mamy modem w wersji klasycznej, czyli to nie ma znaczenia

1.06 powinno obsługiwać E3131 (nawet znacznie nowsze modemy są w pełni obsługiwane już w 1.04) co potwierdza oficjalna lista zgodności
http://www.dlink.com/pl/pl/-/media/consu...0112q4.pdf

Statystyki Folding@home
[Obrazek: sigimage.php?un=szopen&t=247478]
Odwiedź stronę użytkownika Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
06-02-2018, 15:31
Post: #9
RE: D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
Zresetowałem router do ustawień fabrycznych i ustawiłem w modemie na "preferowany WCDMA" i dalej to samo. Dodaje w załączniku screeny.


Załączone pliki Miniatury
           
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
06-02-2018, 18:25
Post: #10
D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
możesz pobrać kompletny log (przycisk pobierz na 1 SS, tam widać tylko 1/3 logu) i wrzucić go jako załącznik lub po prostu jako tekst

faktycznie drugi SS wygląda tak, jakby modem nie był rozpoznawany, jesteś pewien, że to nie jest HiLink?
(E3131s-2 "tradycyjny" i bez brandu to raczej rzadkość w PL, może ma inny PID niż pozostałe wykonania E3131?)

jeśli masz możliwość pożyczyć inny modem to zrób to, bo nie chcę namawiać do zmiany firmware w routerze (jeśli fabryczne hasło logowania do webGUI nie jest puste, to może być problem po downgrade)
ponadto powrót do softu po polsku może nie być możliwy (jak rozumiem Playa, choć pomarańczowa kolorystyka jakoś mi nie do tego pasuje Big Grin jakkolwiek nie miałem nigdy w ręce Playowskiej wersji tego routera)

Statystyki Folding@home
[Obrazek: sigimage.php?un=szopen&t=247478]
Odwiedź stronę użytkownika Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
06-02-2018, 19:08
Post: #11
RE: D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
szopen napisał(a):możesz pobrać kompletny log (przycisk pobierz na 1 SS, tam widać tylko 1/3 logu) i wrzucić go jako załącznik lub po prostu jako tekst

oto cały log:
Cytat:*******************************
2013/01/01 01:01:51
*******************************
Jan 1 00:59:57 kernel: klogd started: BusyBox v1.3.2 (2015-12-03 20:04:09 CST)
Jan 1 00:59:59 BEID: BEID STATUS : 0 , STATUS OK!
Jan 1 01:00:03 commander: NETWORK Initialization finished. Result: 0
Jan 1 01:00:03 commander: Initialize MultiWAN
Jan 1 01:00:03 commander: wantype = 16, wantype index = 0, wan mode = 1, route enable = 1
Jan 1 01:00:03 commander: fo enable = 0, fo stay enable = 0, fo trigger = 0, fo time = 0, fo sequence = 0
Jan 1 01:00:03 commander: LOAD BALANCE!
Jan 1 01:00:03 commander: ROUTING!
Jan 1 01:00:03 commander: Init NAT Server
Jan 1 01:00:07 syslog: server_config.pool_check = 1
Jan 1 01:00:07 syslog: start = 192.168.0.50, end = 192.168.0.199, lan_ip = 192.168.0.1, interface=br0, ifindex=0
Jan 1 01:00:07 udhcpd[2151]: udhcpd (v0.9.9-pre) started
Jan 1 01:00:07 commander: SPAP!
Jan 1 01:00:07 commander: SNMP_Customer_id=0
Jan 1 01:00:07 commander: SNMP!
Jan 1 01:00:07 commander: ROUTE PROTOCOL!
Jan 1 01:00:07 commander: enable Daylight saving...
Jan 1 01:00:07 commander: TIME!
Jan 1 01:00:07 MultiWANChk2: 13 : wan_mode = 1
Jan 1 01:00:07 commander: [init_iom][40]
Jan 1 01:00:07 commander: iom disable
Jan 1 01:00:07 commander: Kill Previous dido PID
Jan 1 01:00:09 init: Starting pid 2297, console /dev/ttyS1: '/bin/ash'
Jan 1 01:00:10 commander: Commander Monitor pid 0x8ea
Jan 1 01:00:10 commander: Wireless 8021X Stop
Jan 1 01:00:10 commander: NAT Restart
Jan 1 01:00:12 O3G/modem_switch: MODEM_SWITCH [0x12d1] [0x14fe]
Jan 1 01:00:14 commander: Start/Restart AP Management !!
Jan 1 01:00:16 commander: NAT Restart
Jan 1 01:00:18 O3G/usblist: 3G 0 modem VendorID=[12d1] ProductID=[14fe]
Jan 1 01:00:20 O3G/usblist: remove_driver 5597: REMOVE_USBSTORAGE
Jan 1 01:00:27 commander: nf_handle_macctl_wlanap 1102 iwpriv ra0 set AccessPolicy=0
Jan 1 01:00:37 O3G/modem_switch: MODEM_SWITCH [0x12d1] [0x14fe]
Jan 1 01:00:43 O3G/usblist: 3G 0 modem VendorID=[12d1] ProductID=[14fe]
Jan 1 01:00:45 O3G/usblist: remove_driver 5597: REMOVE_USBSTORAGE
Jan 1 01:00:50 O3G/usblist: 3G 0 modem VendorID=[12d1] ProductID=[1506]
Jan 1 01:00:51 O3G/usblist: chk_interface_num ret:6
Jan 1 01:01:15 O3G/3g_queryd_0: check_modem_info[imsi=]
Jan 1 01:01:16 O3G/3g_queryd_0: check_modem_info[imsi=]
Jan 1 01:01:17 O3G/3g_queryd_0: check_modem_info[model=N/A]
Jan 1 01:01:17 O3G/3g_queryd_0: check_modem_info[signal_strength=0]
Jan 1 01:01:18 O3G/3g_queryd_0: check_modem_info[signal_strength=0]
Jan 1 01:01:19 O3G/3g_queryd_0: check_modem_info[signal_strength=0]
Jan 1 01:01:20 O3G/3g_queryd_0: check_modem_info[signal_strength=0]
Jan 1 01:01:21 O3G/3g_queryd_0: check_modem_info[signal_strength=0]

szopen napisał(a):faktycznie drugi SS wygląda tak, jakby modem nie był rozpoznawany, jesteś pewien, że to nie jest HiLink?
(E3131s-2 "tradycyjny" i bez brandu to raczej rzadkość w PL, może ma inny PID niż pozostałe wykonania E3131?)

Wersja firmware modemu zaczyna się na "21" więc wnioskuje po tym, że jest to właśnie s2. Menedżer urządzeń w Windowsie widzi go jako modem
szopen napisał(a):jeśli masz możliwość pożyczyć inny modem to zrób to, bo nie chcę namawiać do zmiany firmware w routerze (jeśli fabryczne hasło logowania do webGUI nie jest puste, to może być problem po downgrade)
ponadto powrót do softu po polsku może nie być możliwy (jak rozumiem Playa, choć pomarańczowa kolorystyka jakoś mi nie do tego pasuje Big Grin jakkolwiek nie miałem nigdy w ręce Playowskiej wersji tego routera)
Fabryczna wersja softu to była "1.00(Play)"

Jest też taka możliwość, że nie gra to przez grzebanie w programie top_netinfo? Kiedyś się bawiłem tym jak potrzebowałem żeby mi obsłużył tablet ten modem.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
06-02-2018, 19:54
Post: #12
D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
Modem wykryty, tylko dalej się nie wykrywa prawidłowo.
Ja chętnie zobaczę ten router z bliska - w Warszawie. Przy okazji mogę sprawdzić modem i z innym modemem router.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
06-02-2018, 22:37
Post: #13
D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
Ekin napisał(a):Jest też taka możliwość, że nie gra to przez grzebanie w programie top_netinfo? Kiedyś się bawiłem tym jak potrzebowałem żeby mi obsłużył tablet ten modem.

jeśli pamiętasz (a raczej masz zapisane) co zmieniłeś, to można przywrócić

zapewne chodzi o
AT^SETPORT="A1,A2;1,16,3,2,A1,A2"
(powyższa komenda ustawia typowy układ podurządzeń dla tego modemu przed i po przełączeniu)

ale najpierw wykonaj (aby się dowiedzieć jakie masz obecne ustawienia)
AT^SETPORT?

Statystyki Folding@home
[Obrazek: sigimage.php?un=szopen&t=247478]
Odwiedź stronę użytkownika Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
07-02-2018, 11:57 (Ten post był ostatnio modyfikowany: 07-02-2018 12:04 przez Ekin.)
Post: #14
RE: D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
szopen napisał(a):ale najpierw wykonaj (aby się dowiedzieć jakie masz obecne ustawienia)
AT^SETPORT?
Wyszło mi:
Cytat:Polecenie:
AT^SETPORT?
Odpowiedź:
AT^SETPORT?

^SETPORT:A1,A2;3,2,1,16,A1,A2

OK
Niestety nie wiem jak to wyglądało na początku :/
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
07-02-2018, 13:17 (Ten post był ostatnio modyfikowany: 07-02-2018 13:18 przez szopen.)
Post: #15
D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
U Ciebie kolejność występowania urządzeń jest raczej zmieniona (co mogło mieć znaczenie dla skryptu w tablecie)
więc myślę, że bez strachu możesz ustawić kolejność tym poleceniem które podałem trochę wyżej
(podałem jak wygląda standartowo, choć jest to wartość wygrzebana w necie)

gdybyś potrzebował użyć modemu z tym tabletem, to po prostu znów przestawisz takim poleceniem:
AT^SETPORT="A1,A2;3,2,1,16,A1,A2"

Statystyki Folding@home
[Obrazek: sigimage.php?un=szopen&t=247478]
Odwiedź stronę użytkownika Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
07-02-2018, 17:21
Post: #16
D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
Zmieniłem kolejność i problem występuje nadaz z routerem. Szkoda mi już czasu grzebać się z tym zestawem. Sprawdziłem router ze starym E173 i odpalił bez trudu, czyli wina leży po stronie modemu. Zamierzam kupić coś z LTE, czy E3372 będzie dobrym wyborem?
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
08-02-2018, 09:22
Post: #17
D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
Szczerze mówiąc mnie ciekawi, na czym polega problem, bo właśnie pomagam w grzebaniu w tym routerze w celu dołożenia pełnej obsługi OpenWRT.
Poprzestawiam kolejność urządzeń i zobaczę.
Co do meritum pytania:
Ekin napisał(a):Zamierzam kupić coś z LTE, czy E3372 będzie dobrym wyborem?
Tak, ten modem działa świetnie z DWR-116.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
08-02-2018, 10:06 (Ten post był ostatnio modyfikowany: 08-02-2018 11:08 przez szopen.)
Post: #18
D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
Zmieniłem kolejność na:
SETPORT:A1,A2;3,2,1,16,A1,A2 (polecenie brzmi: AT^SETPORT="A1,A2;3,2,1,16,A1,A2" )

I faktycznie router przestał się łączyć. Następnie modem przywróciłem na:

SETPORT:A1,A2;1,16,3,2,A1,A2 (poleceniem AT^SETPORT="A1,A2;1,16,3,2,A1,A2" )

I działa bez problemu.

Wniosek 1. DWR-116 jest tak głupim routerem, że nie próbuje wykryć, do czego służą poszczególne porty USB modemu i zakłada domyślną kolejność.
Wniosek 2. Ekin: nie zmieniłeś prawidłowo kolejności portów w swoim E3131. Gdy ja to zrobiłem wszystko zadziałało zgodnie z oczekiwaniami. Więc o ile nie potrzebujesz teraz od razu LTE, to powyższa instrukcja zmiany kolejności portów powinna rozwiązać twój problem i nie musisz kupować natychmiast modemu E3372 (oczywiście to wcale nie zaszkodzi).
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
[-] 1 użytkownik podziękował użytkownikowi jakubd za tę wiadomość:
Ekin (2018-02-08)
08-02-2018, 20:30 (Ten post był ostatnio modyfikowany: 08-02-2018 20:38 przez Ekin.)
Post: #19
D-Link DWR-116 + Huawei E3131s-2 router nie widzi modemu
jakubd napisał(a):Wniosek 2. Ekin: nie zmieniłeś prawidłowo kolejności portów w swoim E3131. Gdy ja to zrobiłem wszystko zadziałało zgodnie z oczekiwaniami. Więc o ile nie potrzebujesz teraz od razu LTE, to powyższa instrukcja zmiany kolejności portów powinna rozwiązać twój problem i nie musisz kupować natychmiast modemu E3372 (oczywiście to wcale nie zaszkodzi).
Faktycznie, teraz wszystko łączy elegancko Big Grin. Dzięki wielkie za pomoc.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
Odpowiedz 


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  huawei e5577cs-321 przejściówka do anteny z wtykiem RS-SMA drophead 9 730 28-03-2020 23:02
Ostatni post: drophead
  Asus RT-AC51U + Huawei e3373h-153 - słaba prędkość egotrip 1 528 06-02-2020 06:10
Ostatni post: szopen
  router do nju lalalala 70 9 438 19-11-2019 14:57
Ostatni post: Ekonomista
  Asus RT-AC51u, TP-Link TL-MR3420 i Huawei E3372s-153 oem 24 46 877 25-03-2019 15:54
Ostatni post: mshmaster
  Przy próbie pobrania łatki SSH w Xiaomi router 3g wyskakuje powiadomienie lolokm 44 5 362 14-03-2019 22:42
Ostatni post: lolokm