[-]
Szybkie szukanie


Baner sklepu jdtech.pl
Odpowiedz 
 
Ocena wątku:
  • 0 Głosów - 0 Średnio
  • 1
  • 2
  • 3
  • 4
  • 5
Huawei E3131s-2 oraz openSUSE 13.1
18-05-2014, 14:31
Post: #1
Huawei E3131s-2 oraz openSUSE 13.1
Wie ktoś może jak połączyć się z internetem za pomocą Huawei E3131s-2 w openSUSE 13.1?
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
18-05-2014, 17:06
Post: #2
Huawei E3131s-2 oraz openSUSE 13.1
Napisz, na czym stanąłeś.
Jaki to E3131s-2 - HiLink, czy zwykły?
Co wyświetla 'lsusb'?
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
18-05-2014, 17:14
Post: #3
Huawei E3131s-2 oraz openSUSE 13.1
lsusb wyświetla:
polish@linux-bl7b:~> lsusb
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 1307:0330 Transcend Information, Inc. 63-in-1 Multi-Card Reader/Writer
Bus 001 Device 004: ID 0930:6545 Toshiba Corp. Kingston DataTraveler 102 Flash Drive / HEMA Flash Drive 2 GB / PNY Attache 4GB Stick
Bus 001 Device 005: ID 1131:1004 Integrated System Solution Corp. Bluetooth Device
Bus 002 Device 003: ID 12d1:1506 Huawei Technologies Co., Ltd. E398 LTE/UMTS/GSM Modem/Networkcard
polish@linux-bl7b:~>
Modem zwykły
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
18-05-2014, 17:25
Post: #4
Huawei E3131s-2 oraz openSUSE 13.1
Modem masz rozpoznany przez system i gotowy do połączenia.
Teraz musisz znaleźć w interfejsie okienkowym jakiegoś Network Managera lub Connection Managera (lub odpowiednika), który obsługuje połączenia komórkowe. Czasem (nie wiem, jak w SuSE, skończyłem z nim współpracę na wersji 5) jest to ta sama aplikacja, co do WiFi.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
18-05-2014, 18:26
Post: #5
Odp: RE: Huawei E3131s-2 oraz openSUSE 13.1
(18-05-2014 17:14)polp napisał(a):  Bus 002 Device 003: ID 12d1:1506 Huawei Technologies Co., Ltd. E398 LTE/UMTS/GSM Modem/Networkcard
polish@linux-bl7b:~>
Modem zwykły

Masz e3131 czy e398?

從我的 用 Galaxy Note II LTE 發送
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
18-05-2014, 18:27 (Ten post był ostatnio modyfikowany: 18-05-2014 18:39 przez polp.)
Post: #6
Huawei E3131s-2 oraz openSUSE 13.1
Huawei E3131s-2 ze sklepu jdtech.
Po kliknięciu w ikonke w trayu wyskakuje okieno przecięte na poł, z lewej pisze interfejscy i na dole jest do zaznaczenia Włącz sieć po zaznaczeniu nic sie nie dzieje. Po prawej są połączenia i tam do wyboru mam pokaż wiecej... którego kliknąć sie nie da oraz zarządzaj połączeniami.. po kliknięciu pojawia się nowe okienko tam mam jakieś zakładi do wyboru kliknąć mogę tylko VPN pozostałe czyli DSL, przewodowe, bezprzewodowe i mobilne szerokopasmowe są nieaktywne, nie da się ich wybrać.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
18-05-2014, 18:32
Post: #7
Odp: Huawei E3131s-2 oraz openSUSE 13.1
Ciekawe czemu wyswietla jak e398 moze jakub wyrzezbil tak fw Smile

從我的 用 Galaxy Note II LTE 發送
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
18-05-2014, 19:21
Post: #8
Huawei E3131s-2 oraz openSUSE 13.1
Skoro jako e398 go wykrywa to może złe komendy mu linux wysyła i dlatego nie dziala?
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
18-05-2014, 20:30
Post: #9
Huawei E3131s-2 oraz openSUSE 13.1
Według mnie dobrze wykrywa, tylko źle opisuje. 12d1:1506 wskazuje, że modem został rozpoznany i przełączony w tryb modemu.
Nie daje sobie rady tylko konfiguracja sieci - mobilne szerokopasmowe powinno być aktywne. Dalej trzeba szukać niestety na forach specjalizujących się w SuSE.
Na pewno można odpalić połączenie z palca za pomocą skryptu analogicznie jak dla Debiana: http://dug.net.pl/tekst/197/aero2_z_mode...wei_e3131/
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
18-05-2014, 21:22
Post: #10
Huawei E3131s-2 oraz openSUSE 13.1
Mam problem przy Konfiguracji wvdial, gdy chcę otworzyć plik wvdial.conf wyskakuje "Brak dostępu do file:///etc/wvdial.conf." Inne pliki .conf otwierają sie normalnie w edytorze tekstowym, wiecie o co może chodzic?
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
18-05-2014, 21:31
Post: #11
Huawei E3131s-2 oraz openSUSE 13.1
Musisz mieć prawa roota
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
18-05-2014, 21:41
Post: #12
Huawei E3131s-2 oraz openSUSE 13.1
Chodzi o wpisanie w konsole su i potem hasła? Jeśli tak to nie działa.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
19-05-2014, 09:54
Post: #13
Huawei E3131s-2 oraz openSUSE 13.1
Nie wiem jaką metodologię stosuje openSuSE, ale powinno być jak w Ubuntu - nie można zrobić samego su - możesz tylko odpalić jakiś program na prawach roota, np.
sudo mc (o ile jest w systemie)
sudo su (po prostu masz konsolę na prawach roota)
albo możesz po prostu spod prawego klawisza odpalić coś jako root - często jest taka opcja. Szczegóły zależą od... twórców dystrybucji.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
19-05-2014, 16:51 (Ten post był ostatnio modyfikowany: 19-05-2014 17:49 przez jakubd.)
Post: #14
Huawei E3131s-2 oraz openSUSE 13.1
Przełączyłem użytkownika i zalogowałem sie jako root, edytowalem wvdial według tego http://forum.jdtech.pl/Watek-huawei-e313...-to-dziala
w konsole wvdial aero2 i wyskakuje:
Kod:
linux-bl7b:~ # wvdial aero2
--> WvDial: Internet dialer version 1.61
--> Initializing modem.
--> Sending: AT+CGDCONT=1,"IP","darmowy","",0,0
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2
OK
--> Modem initialized.
--> Idle Seconds = 300, disabling automatic reconnect.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT 21600000
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Mon May 19 16:40:38 2014
--> Pid of pppd: 2762
--> Using interface ppp0
--> pppd: ?[7f]
--> pppd: ?[7f]
--> pppd: ?[7f]
--> pppd: ?[7f]
--> pppd: ?[7f]
--> pppd: ?[7f]
--> local  IP address 78.30.88.159
--> pppd: ?[7f]
--> remote IP address 10.64.64.64
--> pppd: ?[7f]
--> primary   DNS address 193.41.112.18
--> pppd: ?[7f]
--> secondary DNS address 193.41.112.14
--> pppd: ?[7f]
--> Script /etc/ppp/ip-up run successful
--> Default route Ok.
--> warning, can't find address for `www.suse.de`
--> warning, address lookup does not work
--> Nameserver (DNS) failure, the connection may not work.
--> Connected... Press Ctrl-C to disconnect
--> pppd: ?[7f]
I internet nie działą, wie ktoś o co chodzi?
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
19-05-2014, 17:49
Post: #15
Huawei E3131s-2 oraz openSUSE 13.1
Logi wskazują na to, że działa - do czasu rozłączenia. Teraz musisz wprowadzić kod CAPTCHA (wejść na stronę nieszyfrowaną, np. wp.pl i powinno cię przekierować), po czym rozłączyć się i połączyć ponownie.
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
19-05-2014, 18:39 (Ten post był ostatnio modyfikowany: 19-05-2014 19:51 przez jakubd.)
Post: #16
Huawei E3131s-2 oraz openSUSE 13.1
Nadal nie działa sprawdzałem na wp.pl, o2.pl, google.pl oraz bezpośrednio na http://bdi.free.aero2.net.pl:8080 na 2 przeglądarkach Sad w konsoli jest to:
Kod:
linux-bl7b:/home/polish # wvdial aero2
--> WvDial: Internet dialer version 1.61
--> Initializing modem.
--> Sending: AT+CGDCONT=1,"IP","darmowy","",0,0
AT+CGDCONT=1,"IP","darmowy","",0,0
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2
ATQ0 V1 E1 S0=0 &C1 &D2
OK
--> Modem initialized.
--> Idle Seconds = 300, disabling automatic reconnect.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT 21600000
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Mon May 19 18:33:05 2014
--> Pid of pppd: 3020
--> Using interface ppp0
--> pppd: �[7f]
--> pppd: �[7f]
--> pppd: �[7f]
--> pppd: �[7f]
--> pppd: �[7f]
--> pppd: �[7f]
--> local  IP address 37.209.142.82
--> pppd: �[7f]
--> remote IP address 10.64.64.64
--> pppd: �[7f]
--> primary   DNS address 193.41.112.18
--> pppd: �[7f]
--> secondary DNS address 193.41.112.14
--> pppd: �[7f]
--> Script /etc/ppp/ip-up run successful                                                                                                                                          
--> Default route Ok.                                                                                                                                                              
^[[A                                                                                                                                                                              
^[[A^[[A--> warning, can't find address for `www.suse.de`                                                                                                                          
--> warning, address lookup does not work
--> Nameserver (DNS) failure, the connection may not work.
--> Connected... Press Ctrl-C to disconnect
--> pppd: �[7f]
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
19-05-2014, 19:52
Post: #17
Huawei E3131s-2 oraz openSUSE 13.1
Wyświetl na kolejnej konsoli
ifconfig /all
nslookup wp.pl
(jakie masz DNSy w systemie? jeżeli ustawiłeś ręcznie jakieś inne, niż te z Aero2, to niestety nie zadziała nic jak trzeba).
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
19-05-2014, 20:29 (Ten post był ostatnio modyfikowany: 09-06-2015 12:54 przez szopen.)
Post: #18
Huawei E3131s-2 oraz openSUSE 13.1
Po wpisaniu tych komend:

Kod:
linux-bl7b:~ # ifconfig /all
/all: error fetching interface information: Device not found
linux-bl7b:~ # nslookup wp.pl
;; connection timed out; no servers could be reached

A jakie DNSy mam to nie wiem Big Grin
@Edit:
DNSy to chyba 193.41.112.18 i 193.41.112.1 przynajmniej wedlug tego co pokazuje konsola po połączeniu:

Kod:
linux-bl7b:~ # wvdial aero2
--> WvDial: Internet dialer version 1.61
--> Initializing modem.
--> Sending: AT+CGDCONT=1,"IP","darmowy","",0,0
AT+CGDCONT=1,"IP","darmowy","",0,0
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2
ATQ0 V1 E1 S0=0 &C1 &D2
OK
--> Modem initialized.
--> Idle Seconds = 300, disabling automatic reconnect.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT 21600000
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Tue May 20 08:01:23 2014
--> Pid of pppd: 2498
--> Using interface ppp0
--> pppd: �[7f]
--> pppd: �[7f]
--> pppd: �[7f]
--> pppd: �[7f]
--> pppd: �[7f]
--> local  IP address 84.39.175.172
--> pppd: �[7f]
--> remote IP address 10.64.64.64
--> pppd: �[7f]
--> primary   DNS address 193.41.112.18
--> pppd: �[7f]
--> secondary DNS address 193.41.112.14
--> pppd: �[7f]
--> Script /etc/ppp/ip-up run successful
--> Default route Ok.

Kod:
A to pokazuje się po chwili od połączenia:
--> warning, can't find address for `www.suse.de`
--> warning, address lookup does not work
--> Nameserver (DNS) failure, the connection may not work.
--> Connected... Press Ctrl-C to disconnect
--> pppd: �[7f]

Po wpisaniu jakiegoś adresu w przeglądarce pisze connecting i nic sie nie dzieje. Może by tak inne serwery DNS ustawić? Jeśli to coś pomoże to proszę o opis jak to zrobić.

//uzupełnienie przez moderatora
Uwaga od wiosny 2015 czyli integracji z siecią Plusa obowiązują nowe adresy serwerów DNS, są to
212.2.96.51
i
212.2.96.52

zastępują one poprzednio używane serwery Sferii 193.41.112.18 i 193.41.112.14
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
20-05-2014, 10:42
Post: #19
Huawei E3131s-2 oraz openSUSE 13.1
Ech praca na ślepo.
1. ifconfig bez dodatkowych argumentów zadziała.
2. sprawdzanie DNSów już nie jest takie proste, ale na początek wystarczy może
cat /etc/resolv.conf
a jak wyjdzie 127.0.0.1 to jeszcze
nm-tool o ile jest zainstalowany
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
20-05-2014, 18:51 (Ten post był ostatnio modyfikowany: 09-06-2015 12:56 przez szopen.)
Post: #20
Huawei E3131s-2 oraz openSUSE 13.1
Udało się zrobiłem (Dzięki wielkie wszystkim za pomoc) Big Grin

Napisze jak, pewnie przyda się innym, nazwy będą po angielsku bo na roocie nie mam polskiego (chyba będzie najlepiej to robić na koncie roota, żeby na nie wejść trzeba się wylogować, po tym wpisać nazwę użytkownika root i hasło),

więc najpierw trzeba uruchomić yast2 wybrać Network Devices
potem Network Settings.
W Global Options Ustawiamy Network Setup Method na User Controlled with NetworkManager.
Jeśli jest zaznaczone Enable IPv6 to odznaczamy, po zrobieniu wszystkiego klikamy ok.
Potem klikamy ikonkę od NetworkManager'a (u mnie ma ikonkę telefonu nie wiem jak u innych) jeśli jej nie ma trzeba zrestartować komputer powinna się pojawić.
Wybieramy Manage Connections...
klikamy zakładkę Mobile Broadband, wybieramy Add... next,
wybieramy nasz kraj, next, wybieramy z listy aero2, next i Finish.

Wyskoczy nowe okno ustawienia w pierwszej zakładce powinny być takie: Number:*99#
Username:(nic)
Password: (nic)
APN:darmowy
Type:Any,
zaznaczamy Allow roaming,
PIN:(też nic).

W zakładce PPP nic nie zmieniamy, w zakładce IPv4 Address pierwsze do wyboru Basic settings, Method:Automatic (PPP), Additional DNS Servers
(ja sobie ustawiłem DNSy chyba google bo bez nich internet nie działa, można dać inne oczywiście): 8.8.8.8 W Additional Search Domains: 8.8.8.4 (to chyba literówka przypuszczalnie chodziło o 8.8.4.4)

Na dole zaznaczamy jeśli nie jest zaznaczone IPv4 is required for this connection.
Zakładka IPv6 Address Basic settings Method Disabled Privacy Extensions: Disabled
u góry zaznaczamy Connect automatically jeśli chcemy żeby internet łączył się automatycznie, klikamy OK.
Jeśli nie zaznaczyliśmy automatycznego łączenia żeby się połączyć klikamy ikonkę network manager'a i z listy Connections wybieramy Aero2.

Internet powinien działać Big Grin

Z tymy DNSami pamiętam że gdzieś coś czytałem o tym że (nie oddam dokładnego sensu tego) coś jest nie tak z nimi jeśli korzystamy z Aero2 w openSUSE 13.1.
szopen - ja proponuję te: 212.2.96.51 i 212.2.96.52 czyli DNSy Plusa, czyli oficjalne w Aero2 zamiast googlowskich 8.8.8.8 i 8.8.4.4 ze względu na mechanizm captcha

jakubd jeśli chcesz można by zrobić poradnik ze zdjęciami jak skonfigurować Aero2 w openSUSE 13.1 Big Grin mógłbym porobić zdjęcia, a Ty resztę, bo pisarz ze mnie raczej słaby Big Grin
Jeszcze raz dzięki wszystkim za pomoc ;D

@Edit: Jeśli ikonka network managera się nie pojawi można ja dodać klikając w prawym dolnym rogu małą okrągłą ikonkę potem dodaj elementy interfejsu... i szukamy (będzie po polsku nie wiem jak to nazywa się po angielsku bez spolszczenia) Zarządzanie siecią (wygląda jak przekręcone a, jest trochę niebieski, żeby go znaleźć wystarczy przewinąć listę maksymalnie na prawo, u mnie jest dziesiąty od końca, dodajemy go dwuklikiem)

//uzupełnienie
Uwaga od wiosny 2015 czyli integracji z siecią Plusa obowiązują nowe adresy serwerów DNS, są to
212.2.96.51
i
212.2.96.52

zastępują one poprzednio używane serwery Sferii 193.41.112.18 i 193.41.112.14
Znajdź wszystkie posty użytkownika
Podziękuj Odpowiedz cytując ten post
Odpowiedz 


Podobne wątki
Wątek: Autor Odpowiedzi: Wyświetleń: Ostatni post
  Huawei - ostatnia oficjalna i dostępna wersja Mobile Partner szopen 0 2 135 25-08-2019 12:50
Ostatni post: szopen
  [ROZWIĄZANY] błąd w aplikacji play E3131s-2 alaskan_malamute 2 1 747 24-08-2019 21:14
Ostatni post: jakubd
  Huawei E3131 Firmware lukkki 74 153 867 24-12-2018 14:49
Ostatni post: jakubd
  huawei E3131 top netinfo połaczony AERO2,neta brak adikSl 9 4 208 09-12-2018 17:07
Ostatni post: szopen
  Huawei 3131 Hlink, wszystko ok ale connection failded bereal 4 2 579 06-12-2018 00:19
Ostatni post: bereal